LinuxSever.Com - Türkiye'nin Linux platformu
IzzyMenu.com

Go Back   LinuxSever.Com - Türkiye'nin Linux platformu > 3. Parti Yazılımları > Güvenlik Uygulamaları

Güvenlik Uygulamaları İşletim sistemi güvenliği için sisteminizde kurulu olması gereken yazılımlar hakkında bilgi ve destek forumu

Cevapla
 
Seçenekler Stil
Alt 05-23-2009, 07:43 PM   #1 (permalink)
Administrator
 
ismail - ait Kullanıcı Resmi (Avatar)
 
Üyelik tarihi: May 2009
Mesajlar: 121
Standart Httpd floodkoruma

Floodkoruma httpd servisine gelen flood ataklarına karşı testler sonucunda gayet başarılı bulduğumuz ve sizinle paylaşmak istediğimiz güvenlik yazılımlarından bir tanesidir. Yazılım iptables ile birlikte çalışarak, httpd ye gelen atakları iptables ile bloklamaktadır. Bu yazılım 32 bit desteklidir. Aşağıda CentOS işletim sistemi üzerinde iki farklı sürümde kurulum aşamalarını anlatacağım.

CentOS 4.x :

İlk olarak sunucumuzda ssh üzerinden root olarak login oluyoruz.

Kod:
wget http://www.linuxsever.com/dosyalar/i...1.c4x.i386.rpm
rpm -ihv floodkoruma-2.0-1.c4x.i386.rpm --force
Yukarıda rpm paketini çektik ve yükleme işlemini gerçekleştirdik. Yazılımın mevcut standart ayarlarında oynama yapmamız gerekiyor çünkü zararsız bağlantıları da kimi zaman bloklayabiliyor.

Kod:
nano /etc/sysconfig/floodkoruma
Sonraki adımda yukarıdaki komut ile floodkoruma dosyasını açıyoruz. -w 10 yazan kısmı -w 100 yapıyoruz son olarakda -c 18 yazan kısmı -c 180 yapıyoruz yani mevcut satırı aşağıdaki gibi değiştiriyoruz.

Kod:
OPTIONS="-i eth0 -f 'tcp[tcpflags] & tcp-syn != 0 and dst port 80' -w 100 -c 180 -o ipfilter -R 0.0.0.0:0 -a -d -l /var/log/ddos.log -T 3600"
Değişiklikler yapıldıkdan sonra floodkoruma servisini yeniden başlatıyoruz.

Kod:
service floodkoruma restart
ismail isimli Üye şimdilik offline konumundadır   Alıntı ile Cevapla
Alt 05-23-2009, 07:49 PM   #2 (permalink)
Administrator
 
ismail - ait Kullanıcı Resmi (Avatar)
 
Üyelik tarihi: May 2009
Mesajlar: 121
Standart CentOS 5.x için floodkoruma

CentOS 5.x :

CentOS 5.x versiyonlarında CentOS 4.x deki gibi kurulum yapmayı denediğinizde hata ile karşılaşacaksınız. Bunun sebebi floodkorumanın sistemdeki mevcut libpcab paketi ile uyumsuz olmasından kaynaklanmaktadır. Bu sorunuda aşağıdaki adımlarla giderebiliyoruz.

Kod:
wget http://www.linuxsever.com/dosyalar/i...4_6.1.i386.rpm
rpm -ihv libpcap-0.8.3-12.el4_6.1.i386.rpm --force
Yukarıdaki işlemleri gerçekleştirdikden sonra CentOS 4.x sürümleri için anlattığım şekilde kurulumu gerçekleştirebilirsiniz.


Kaynak : İsmail ÇEHRELİ - LinuxServer.Com
ismail isimli Üye şimdilik offline konumundadır   Alıntı ile Cevapla
Alt 06-12-2009, 09:20 PM   #3 (permalink)
Administrator
 
orhan - ait Kullanıcı Resmi (Avatar)
 
Üyelik tarihi: May 2009
Mesajlar: 331
Standart

SYN ataklarında etkili bir yazılım
emeğine sağlık ismail hoca
orhan isimli Üye şimdilik offline konumundadır   Alıntı ile Cevapla
Alt 06-25-2009, 04:31 AM   #4 (permalink)
Acemi Penguen
 
Üyelik tarihi: Jun 2009
Mesajlar: 47
Standart Cevap: Httpd floodkoruma

merhabalar bir arkadaş hata almış ancak onun sunucusunda
Centos 5 ,Plesk 9 kurulu
Aldığı Hata Şu şekilde

floodkoruma: unrecognized service
servertr isimli Üye şimdilik offline konumundadır   Alıntı ile Cevapla
Alt 06-25-2009, 11:55 AM   #5 (permalink)
Administrator
 
ismail - ait Kullanıcı Resmi (Avatar)
 
Üyelik tarihi: May 2009
Mesajlar: 121
Standart Cevap: Httpd floodkoruma

kurulum esnasında herhangi bir hata ile karşılaşmış mı?
ismail isimli Üye şimdilik offline konumundadır   Alıntı ile Cevapla
Alt 06-26-2009, 01:18 PM   #6 (permalink)
fso
Acemi Penguen
 
Üyelik tarihi: Jun 2009
Mesajlar: 23
Standart Cevap: Httpd floodkoruma

Sadece syn attacklardamı işe yarıyor yoksa httpd floodlarda etkili oluyormu?
fso isimli Üye şimdilik offline konumundadır   Alıntı ile Cevapla
Alt 06-26-2009, 03:57 PM   #7 (permalink)
Administrator
 
ismail - ait Kullanıcı Resmi (Avatar)
 
Üyelik tarihi: May 2009
Mesajlar: 121
Standart Cevap: Httpd floodkoruma

flood ataklardada etkili
ismail isimli Üye şimdilik offline konumundadır   Alıntı ile Cevapla
Alt 06-27-2009, 08:26 PM   #8 (permalink)
Acemi Penguen
 
Üyelik tarihi: Jun 2009
Mesajlar: 6
Standart Cevap: Httpd floodkoruma

Alıntı:
root@server [~]# rpm -ihv libpcap-0.8.3-12.el4_6.1.i386.rpm --force
ardından
Alıntı:
warning: libpcap-0.8.3-12.el4_6.1.i386.rpm: Header V3 DSA signature: NOKEY, key ID 443e1821
error: Failed dependencies:
kernel >= 2.2.0 is needed by libpcap-0.8.3-12.el4_6.1.i386
gibi bir hata alıyorum ne yapmam gerek ?
AXSOY isimli Üye şimdilik offline konumundadır   Alıntı ile Cevapla
Alt 06-27-2009, 10:15 PM   #9 (permalink)
Administrator
 
ismail - ait Kullanıcı Resmi (Avatar)
 
Üyelik tarihi: May 2009
Mesajlar: 121
Standart Cevap: Httpd floodkoruma

Kurmaya çalıştığınız virtuozzo ya da hypervm ile bölünmüş bir vps mi?
ismail isimli Üye şimdilik offline konumundadır   Alıntı ile Cevapla
Alt 06-28-2009, 04:11 AM   #10 (permalink)
Acemi Penguen
 
Üyelik tarihi: Jun 2009
Mesajlar: 6
Standart Cevap: Httpd floodkoruma

ikiside değil ama openvz kullanan bi sistem ile bölünmüş sunuc olarak sorunuzun cevabı "evet"
AXSOY isimli Üye şimdilik offline konumundadır   Alıntı ile Cevapla
Cevapla
Tags:



Konuyu Toplam 1 Üye okuyor. (0 Kayıtlı üye ve 1 Misafir)
 
Seçenekler
Stil

Yetkileriniz
Konu Acma Yetkiniz Yok
Cevap Yazma Yetkiniz Yok
Eklenti Yükleme Yetkiniz Yok
Mesajınızı Değiştirme Yetkiniz Yok

BB code is Açık
Smileler Açık
[IMG] Kodları Açık
HTML-Kodu Kapalı
Trackbacks are Açık
Pingbacks are Açık
Refbacks are Açık